CircleCI CLI - Context Command errors with "Must have admin permission"

If you encounter the following error while running a Context command while using the CircleCI CLI:

Error: failed to load context list: Non-nullable field was null. Must have admin permission.

First, ensure you are an admin in your organization's VCS (GitHub or Bitbucket). The Org Admin restriction is in place as an additional layer of security for utilizing the CLI to manage Contexts. Without this, the only other option would be to manage Contexts via the UI. 

If you are an Org Admin and still encounter the above error, verify you have run circleci setup and entered your Personal API Token.

If the Personal API Token is missing or incorrect, the same error message will occur

Note: for CLI version 0.1.6772 to current

Was this article helpful?
0 out of 2 found this helpful

Comments

0 comments

Article is closed for comments.