Docker に postgresql-client-9.6 をインストールする際のエラー

一部の dubian ベースの Docker イメージに postgresql-client-9.6 をインストールする際は、次の問題が発生することがあります。

The following packages have unmet dependencies: 
postgresql-client-9.6 : Depends: libpq5 (>= 9.6.6) but 9.4.15-0+deb8u1 is to be installed 
E: Unable to correct problems, you have held broken packages.

これは、使用している特殊バージョンのイメージの上流の問題と関係があります。 CircleCI は、Docker Hub の公式言語リポジトリから Docker イメージをビルドします。 つまり、この種類の問題に関する長期的な修正は、イメージ自体の上流で行なう必要があります。

この問題点を回避するため、Postgresql により推奨される手法を使用できます。 Debian Jessie ベースのイメージ (現在の共通ベースイメージ) では、ビルドで次のような方法を使用します。

- run:
 name: Install PostgreSQL Client
 command: |

 echo "deb http://apt.postgresql.org/pub/repos/apt/ jessie-pgdg main" | sudo tee /etc/apt/sources.list.d/pgdg.list

 wget --quiet -O - https://www.postgresql.org/media/keys/ACCC4CF8.asc | sudo apt-key add -

 sudo apt-get update

 sudo apt-get install postgresql-client-9.6
この記事は役に立ちましたか?
1人中1人がこの記事が役に立ったと言っています

コメント

0件のコメント

ログインしてコメントを残してください。