How to Fix Pipelines Page Performance

Symptoms

  • The Pipelines page loads slowly or becomes unresponsive
  • Browser performance degrades when viewing workflows
  • Page may freeze or lag when scrolling
     

Cause

This issue occurs when workflows contain a large number of jobs. When all jobs are expanded by default, the browser must render many DOM nodes simultaneously, which can significantly impact page performance.
 

Solution

The solution is to turn off the 'Expand all' setting that can be found in the 'Display options'. This setting is universal, in other words when the change is made to one project, it affects all projects. The steps to turn off 'Expand all' are:

  1. Navigate to the Pipelines page for your project via the left-hand sidebar
  1. Locate the Display options menu. You should find it on right hand side of the page above the pipelines table:

    Note: Depending on your resolution/window size the text label may not appear
  1. Find the "Expand all" toggle and disable it
  1. Once disabled, a blue confirmation message in the bottom right of your screen asking you to refresh your page:

    Once refreshed, you should notice the 'Expand all' setting is now disabled:

With the 'Expand all' setting disabled, you can still view the jobs for each pipeline by clicking on the top down icon to the left of the status badge:
Screenshot 2026-03-03 at 11.42.43.png

Was this article helpful?
0 out of 1 found this helpful

Comments

0 comments

Please sign in to leave a comment.