Some users using the aws-ecr orb are experiencing failed builds when installing the AWS CLI, resulting in the following error:
RequirementParseError: Expected ',' or end-of-list in rsa>=3.1.2,<=4.5.0; python_version=="2.7" at ; python_version=="2.7" You are using pip version 8.1.1, however version 21.0.1 is available. You should consider upgrading via the 'pip install --upgrade pip' command.
This is due to an updated AWS CLI package changing requirements for Python / pip.
It's possible to resolve this issue by requesting a more recent version of the aws-ecr orb:
You can read more about recent releases and implementation on the orb's listing here: