AWS CLI install failing when using aws-ecr orb

Some users using the aws-ecr orb are experiencing failed builds when installing the AWS CLI, resulting in the following error:

RequirementParseError: Expected ',' or end-of-list in rsa>=3.1.2,<=4.5.0; python_version=="2.7" at ; python_version=="2.7"
You are using pip version 8.1.1, however version 21.0.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

This is due to an updated AWS CLI package changing requirements for Python / pip.

It's possible to resolve this issue by requesting a more recent version of the aws-ecr orb:

orbs:
aws-ecr: circleci/aws-ecr@6.15.3

You can read more about recent releases and implementation on the orb's listing here:

https://circleci.com/developer/orbs/orb/circleci/aws-ecr

Was this article helpful?
3 out of 3 found this helpful

Comments

0 comments

Article is closed for comments.