Cannot find an installed Xcode satisfying '11.0.0'

If your Fastfile implements the xcversion action to find and select a specific version of Xcode, in this case Xcode 11, you may find the following error occuring:

[!] Cannot find an installed Xcode satisfying '11.0.0'

Why does this happen?

The xcversion action in Fastlane uses the xcode-install gem behind the scenes and, currently as of Fastlane 2.131.0, the minimum version required by Fastlane is outdated.

Steps to Resolve

In your Gemfile, specify a newer version of xcode-install. At the time of writing, the latest version is 2.6.1:

gem 'xcode-install', '~> 2.6', '>= 2.6.1'

 

Was this article helpful?
1 out of 2 found this helpful

Comments

0 comments

Please sign in to leave a comment.