My workflow fails to run, with the error status "NEEDS SETUP"

If your workflow fails to run and create jobs, and has the status "NEEDS SETUP" in the Workflows page, along with the below error message:

We weren't able to start this workflow.

Encountered errors trying to create workflows from this config: Unsupported or missing workflows config version

For more examples see the Workflows documentation.
 
The likely cause for this is that version 2.1 was specified in the config.yml but `Enable build processing (preview)` was not enabled in the Advanced Settings for the project. 
Was this article helpful?
0 out of 2 found this helpful

Comments

0 comments

Please sign in to leave a comment.