ECONNRESET error causes build failure

If you see errno ECONNRESET or code ECONNRESET or Net::ReadTimeout failures when running network tasks with npm or node in your build it's likely that upgrading the version of nodejs will help:

We recommend:

  • >= 4.4.0
  • >= 5.4.0
  • >= 6.0.0

More discussion on the reasons for this here: https://discuss.circleci.com/t/econnreset-on-npm-install/4793/

Was this article helpful?
0 out of 0 found this helpful

Comments

0 comments

Please sign in to leave a comment.

Articles in this section